Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 11.10 64 bit edition on my Lenovo Thinkpad T520. At that time, I had turn off the discrete graphics through the BIOS settings to preserve battery life. Now, I want to enable the discrete graphics again, but when I do, I cannot increase the resolution of the screen higher than 1024:768.

I checked in the System Settings->Displays and it shows my screen as being "Unknown". I read on how to install the nouveau driver, but can't use the procedure explained in https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia as there is nothing in the "Additional Drivers" dialog box. How can I install the nouveau driver?

Here is the output of $lspci -d10de: -vvvnn

01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:1057] (rev a1) (prog-if 00 [VGA controller])

Subsystem: Lenovo Device [17aa:21cf]
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 16
Region 0: Memory at f2000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at e0000000 (64-bit, prefetchable) [size=256M]
Region 3: Memory at f0000000 (64-bit, prefetchable) [size=32M]
Region 5: I/O ports at 5000 [size=128]
Expansion ROM at f3080000 [disabled] [size=512K]
Capabilities: <access denied>
Kernel modules: nouveau, nvidiafb
share|improve this question
    
possible duplicate of How well do laptops with Nvidia Optimus work? –  Lekensteyn Jan 31 '12 at 14:50
    
I don't think so as my problem is not with Optimus. I have installed the same Ubuntu version in the past on the same machine with the discrete graphics enabled in the BIOS and the problem described above did not occur. From my limited experience, it looks like that because the Nvidia card was disabled through the BIOS settings when I installed Ubuntu, the driver didn't get installed. –  jiboutin Jan 31 '12 at 15:00
    
The nouveau driver supplied with Ubuntu is outdated and does not support recent cards from the NVC0 family, especially with older kernels. Please attach the output of lspci -d10de: -vvvnn to your question. –  Lekensteyn Jan 31 '12 at 15:06

3 Answers 3

The nouveau driver is the open-source driver for nvidia video cards and it is installed by default. To enable the proprietary driver from Nvidia, you have to open Additional drivers, as you already did. I think that this answer here should solve your problem, changing the graphics mode in your BIOS from Optimus to Discrete or Integrated. There are also other solutions involving bumblebee, which is a linux support driver for the Optimus technology and there is the official Ubuntu documentation here.

share|improve this answer
up vote 1 down vote accepted

For some reasons, selecting the "Optimus" option in the BIOS solved the problem. With this option enabled, my Nvidia card is now used. I wonder why selecting the "Discrete Graphics" option in the BIOS settings does not work properly. It seems that only the "Integrated Graphics" and "Optimus" options are fully supported by Ubuntu.

But I might be missing something...

share|improve this answer

To use the nvidia optimus (using 2 graphics cards) in ubuntu you need to install the bumblebee package. This will add the possibility to use the intel onboard graphics cards, but also use the nvidia when you start an app with the optirun prefix. (e.g. optirun firefox)

Project page here: https://github.com/Bumblebee-Project/Bumblebee/wiki/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.