Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Wine on Ubuntu 10.10 along with Office 2007. The "title bar" is missing when I open any Office 2007 program (see the screenshot). So I can't maximize or close the window.

alt text

Also, not sure if this is part of the same problem but when I use the "File -> New" option it tries to bring up a Dialog Box but it hides it behind the main window. But the main window is locked so I can't get to the Dialog box.

Any thoughts on how I could fix either of these problems?

If you need any other info let me know in the comments :)

-Thanks, Will

Edit: After playing around I've found that ANYTHING that opens a Dialog box causes problems. Since the focus is on the "Main window" I can't access the pop-up but since there is a pop-up I can't do anything in the "Main Window" ... a crazy Catch-22.

Also, in case it matters this is a "dual monitor" setup.

share|improve this question
    
Just out of interest, are you running that on a second monitor? –  fluteflute Oct 28 '10 at 14:23
    
yes ... do you think that makes a difference? And because i don't have a toolbar I can't even move it to the other monitor. –  JudoWill Oct 28 '10 at 14:30
    
Yes. I came across it. I thought there was a bug report, but I can't find it now - it's certainly a 'known issue'. In the meantime try moving it while holding down Alt. –  fluteflute Oct 28 '10 at 14:42
    
Even if I turn off my extra monitor and move to a "single monitor setup" I have the same issue. –  JudoWill Oct 28 '10 at 14:50
add comment

closed as off topic by jrg May 22 '12 at 18:59

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers

Install playonlinux and then install office2007 with it. Works almost perfectly.

share|improve this answer
add comment

Please try installing the wine1.3 packages from the Wine PPA, I believe the recent disabling of FORTIFY_SOURCE might help with Office 2007.

https://launchpad.net/~ubuntu-wine/+archive/ppa

share|improve this answer
add comment

Try to run winecfg and change target operating system (Win Xp etc.).

share|improve this answer
    
already in "WinXP" mode ... switching to anything else causes Office to crash before opening. –  JudoWill Oct 28 '10 at 15:49
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.