Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Really am stuck here. I have scoured the net and this seems a fairly common issue pointing to root space. On start up everything seems fine and i get to my users log in page with the 2 users names. However in the bottom right corner is the message in the title. If i log in it just refreshes and goes back to the same log in page.

I have pressed ctrl alt F1 as per the posts and logged in with the IT password set on this pc. However when i enter sudo apt-get clean the system then asks me for a sudo password.

As far as we are aware there is no sudo password on this pc and if there was there are only 3 passwords i ever use and none of them work. I can run other sudo commands however it does not ask me for a password. I have also run the df -h and it looks like i am at 100% as per others posts. Can anyone suggest how i can get around the sudo password or clean up space another way?

Thanks J

share|improve this question
1  
Are you sure it isn't just the user's password? I was unsure from your explanation if you tried re-entering that user's password, and if I missed that, my apologies. –  somoso Jan 31 '12 at 11:43
    
hi i have tried the users passord and the 3 other passwords we have. if i get the password wrong it gives me 3 attempts. If i put the users password in it doesnt say wrong password but takes me back to the original prompt an....we@ACH-Server: ~$ once back here it will not let me enter sudo apt-get clean it simply does nothing but moves down the line and back to the prompt an....we@ACH-Server:~$ –  James Jan 31 '12 at 11:53
    
It drops you to the prompt, because the apt-get clean command has no output. It worked for you, but you don't see the result because there wasn't anything to clean. –  gajdipajti Jan 31 '12 at 12:00

1 Answer 1

Two solutions:

  • Live cd: Boot a live cd, open a terminal, run sudo tune2fs -m 0.5 /dev/sda1 (If your first partition is low on space, and is on ext filesystem. You can check this with a df -T command.) This will regain the root reserved free space, and you can boot normally to clear some more. This will only work on ext[2,3,4]. On the live CD there is no password for sudo, just hit enter-.

  • Recovery mode: After POST, hold down right shift button until GRUB menu appears, select recovery mode. When you get to the menu, remount everything as rw (there is an option for that). And select root. If you haven't set any root password, it will drop you to the root shell immediately. Run apt-get clean and apt-get autoremove. Here you can also run the command written in the live cd solution.

Update As you can log in normally on tty1, run the sudo tune2fs -m 0.5 /dev/sda1 (please replace the partition with the one on which you are low on space)

Let me know if you had any problems.

share|improve this answer
    
ill try that but my technical skills are somewhat limited shall we say. Thanks for the posts guys –  James Jan 31 '12 at 12:02
    
As sudo works, just execute the command. you can check the free space and type with df -T –  gajdipajti Jan 31 '12 at 12:05
    
came up with a message "setting reserved blocks percentage to 0.5% (1244 blocks)" what should i do now ? –  James Jan 31 '12 at 12:16
    
That is good. Now check the free space. There sould be enough to boot normally. –  gajdipajti Jan 31 '12 at 12:26
    
ill try but it does not look like much has changed on the available it still shows as 0% used 100% –  James Jan 31 '12 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.