Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When sharing a mov file from Ubuntu One (See sample URL http://ubuntuone.com/2tmgfbyPMAURzYDraoMo7e ), then opening the file from your web browser such as Firefox, rather than giving you the save as file option it will start streaming the movie file instead. If sharing with friends or family & if the file is large, you don't want to be streaming the file as it may take some time.

Is there a way of forcing the "save as file" option so the user has the option of saving the file to a directory or streaming the file? Other files such zip or pdf do prompt the option. I know I could zip the file but it would be easier if you didn't have to as you won't know which files you share will behave in that manner without testing it. Cheers.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

As of next Wednesday (or Tuesday afternoon, depending on where you are in the world) when the change gets deployed you can add ?attachment=true to any public URL to have it delivered with content-type: attachment. So for example if your public URL as given by the system is http://ubuntuone.com/2tmgfbyPMAURzYDraoMo7e, if you need to force it to be delivered as an attachment you specify http://ubuntuone.com/2tmgfbyPMAURzYDraoMo7e?attachment=true.

Hope this helps.

Update: this is now live.

share|improve this answer
    
G'day Chipaca. Thank you for responding to my question. Once this change is deployed can you advise at which of the process do I add this command / statement? Is it when I publish the file from the Ubuntu one folder (Currently running 10.04) or do I go to the Ubuntu One web site & add the statement to the end of the published URL? Example ubuntuone.com/2tmgfbyPMAURzYDraoMo7e/?attachment=true ? If you could post the steps using the sample URL I supplied above (To better understand), that would be much appreciated. Thank you in advance. Cheers. –  muffinman Feb 1 '12 at 12:35
    
@muffinman I updated my answer to (I believe) address your request. If I have answered your question, could you please “accept” it? Thank you. –  Chipaca Feb 7 '12 at 23:09
    
G'day Chipaca. I just tried it & it works a treat :). Thank you for helping me with this query as I'll be in certain case sharing files using that statement with family & friends. –  muffinman Feb 9 '12 at 9:25
    
Maybe in the future you might have either option when publishing from either the computer or Ubuntu One web site. Thank you once again & I hope other people find this info useful. Cheers. –  muffinman Feb 9 '12 at 9:38
    
We need to make it “just work” for everybody. This is just a stopgap measure for us impatient techies, while we work out the best way to do that. –  Chipaca Feb 10 '12 at 7:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.