Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having some strange networking problems with Ubuntu 11.10.

This is a fresh install but this same machine worked fine with 11.10 before. I actually reinstalled with the very same CD and there has been no hardware changes to my computer. This is on wired Ethernet.

In firefox I can't post to phpbb forums (I hit submit and it keeps loading while nothing happens) and uploading to imgur is stuck at 0%. I can't log into email sometimes.

In both chromium and Midori (both use webkit), I can sometimes post to phpbb forums other times it does not work (same as firefox). Imgur uploads go to 100% then are stuck.

I can't log into email sometimes. I can't login to this very site (using win7 for post). Also when I tried to authenticate to askubuntu using openID and launchpad, I gave my launchpad username, signed in to launchpad and when I was asked to allow to authenticate to Ask Ubuntu, the page would be stuck loading then give me a Error 408 Request Timeout. So I can't even log in to askUbuntu from Ubuntu. Note: Everything works fine on the same machine with Windows 7. I tried disabling the firewall (ufw) and that made no difference. I really want to punch my computer as hard as I can. I am so close to changing distros, heck when I used gentoo I had better networking!

share|improve this question

closed as too localized by Jorge Castro, jrg Jun 14 '12 at 17:10

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
My hunch is you may have a bad connection -- can you try another cable, perhaps? You might want to give your ISP a call and see if they can help out with the issue. –  Jacob Peddicord Jan 31 '12 at 4:58
    
Can you try connecting another computer/device with either Ethernet or wifi? Also you could try rebooting your residential gateway (either router or modem) by unplugging it and plugging it back in 30 to 120 seconds later. You can access your res. gateway configuration by using 192.168.2.1 in your browser and checking to see if there are any errors. Then call your ISP if you're still unable to resolve the problem, they'll appreciate you giving them more detailed information. –  titaniumtux Jan 31 '12 at 5:20
    
Can you try the command: mtr askubuntu.com and tell us what you see? Please edit your initial posting when you have new information instead of adding a comment! –  Michael K Jan 31 '12 at 6:43
    
Note: Everything works fine on the same machine with Windows 7. I tried disabling the firewall (ufw) and that made no difference. –  new_user Jan 31 '12 at 17:33
    
you need to provide some hardware details together with log files such as dmesg: askubuntu.com/questions/14008/… –  fossfreedom Feb 8 '12 at 12:25

1 Answer 1

It can be many things, you have to check the following just to start:

  1. Make sure that your IP address is not conflicting with other IP addresses in your local network. To force assignment of a new IP address using DHCP, run sudo dhclient
  2. Check that the assigned DNS servers are working. As a temporary fix, you can use Google's DNS servers: 8.8.8.8, 8.8.4.4
  3. Can you see if your cable is being show as "disconnected" on the network monitor? (you can also check behind your box to see if the blinking light is still blinking when this type of thing occur.) If it's not, then you have a cable problem or a hardware problem.
  4. Try pinging example.com (ping example.com) and see if you have any packet loss, which can be related to poor cables, a problem with your local gateway (router/adsl) or a problem with your Internet connection. To make sure, put another computer side by side (a laptop for example) and check if you can spot a packet loss or anything else on both of them
  5. Did you changed your "hostname" recently? This is not all related to the problem but can be inconvenient if you manually change /etc/hostname without changing /etc/hosts.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.