Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I wanna know how to install gnome-shell without an internet connection. Can you tell me what are the dependencies that I have to download?

share|improve this question
add comment

1 Answer 1

If you have access to an Ubuntu install with an internet connection and of the same version as yours, you can run (as long as you have administrative privileges) the following command:

apt-get install -d gnome-shell

This will download, without installing, all needed packages.

You can also run:

apt-cache depends gnome-shell

This command gives you the list of dependencies for gnome-shell:

gnome-shell
  Depends: gir1.2-atk-1.0
  Depends: gir1.2-clutter-1.0
  Depends: gir1.2-cogl-1.0
  Depends: gir1.2-folks-0.6
  Depends: gir1.2-freedesktop
  Depends: gir1.2-gdkpixbuf-2.0
  Depends: gir1.2-gee-1.0
  Depends: gir1.2-glib-2.0
  Depends: gir1.2-gmenu-3.0
  Depends: gir1.2-gtk-3.0
  Depends: gir1.2-json-1.0
  Depends: gir1.2-mutter-3.0
  Depends: gir1.2-networkmanager-1.0
  Depends: gir1.2-pango-1.0
  Depends: gir1.2-soup-2.4
  Depends: gir1.2-telepathyglib-0.12
  Depends: gir1.2-telepathylogger-0.2
  Depends: gjs
  Depends: gnome-bluetooth
  Depends: libatk1.0-0
  Depends: libc6
  Depends: libcairo2
  Depends: libcanberra0
  Depends: libclutter-1.0-0
  Depends: libcogl5
  Depends: libcroco3
  Depends: libdbus-glib-1-2
  Depends: libecal1.2-10
  Depends: libedataserver1.2-15
  Depends: libedataserverui-3.0-1
  Depends: libfolks25
  Depends: libgconf2-4
  Depends: libgdk-pixbuf2.0-0
  Depends: libgee2
  Depends: libgirepository-1.0-1
  Depends: libgjs0c
 |Depends: libgl1-mesa-glx
  Depends: <libgl1>
    libgl1-mesa-glx
    libgl1-mesa-swx11
  Depends: libglib2.0-0
  Depends: libgnome-desktop-3-2
  Depends: libgnome-keyring0
  Depends: libgnome-menu-3-0
  Depends: libgstreamer0.10-0
  Depends: libgtk-3-0
  Depends: libical0
  Depends: libjson-glib-1.0-0
  Depends: libmozjs185-1.0
  Depends: libmutter0
  Depends: libnm-glib4
  Depends: libnm-util2
  Depends: libpango1.0-0
  Depends: libpolkit-agent-1-0
  Depends: libpolkit-gobject-1-0
  Depends: libpulse-mainloop-glib0
  Depends: libpulse0
  Depends: libstartup-notification0
  Depends: libtelepathy-glib0
  Depends: libtelepathy-logger2
  Depends: libx11-6
  Depends: libxfixes3
  Depends: libxml2
 |Depends: dconf-gsettings-backend
  Depends: <gsettings-backend>
    dconf-gsettings-backend
  Depends: gconf2
  Depends: caribou
  Depends: cups-pk-helper
  Depends: gnome-settings-daemon
  Depends: gsettings-desktop-schemas
  Depends: gnome-icon-theme-symbolic
  Depends: gnome-icon-theme-full
  Depends: gir1.2-accountsservice-1.0
  Depends: gir1.2-gconf-2.0
  Depends: gir1.2-gkbd-3.0
  Depends: gir1.2-gnomebluetooth-1.0
  Depends: gir1.2-polkit-1.0
  Depends: gir1.2-upowerglib-1.0
  Depends: python
  Depends: pkg-config
    pkg-config:i386
  Depends: mesa-utils
  Recommends: gnome-control-center
  Recommends: gnome-user-guide
  Recommends: gnome-themes-standard
  Recommends: gnome-session-fallback
  Breaks: gnome-control-center
  Breaks: gnome-control-center:i386
  Conflicts: gnome-shell:i386
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.