Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So any luck with this yet? I am running Kubuntu 11.10 x86_64 kernel 3.0.0-16-generic i7 @ 3.8GHz 24GB Ram NVIDIA gtx 260 running the 290.10 Drivers

This actually didn't start happening until I updated the Kernel However it is the same effect, /usr/bin/X is running way over 575M<-Virt 450M<-Res ~80% CPU almost constantly. My machine is lagging hardcore. I used to be able to run multiple vm's hundreds of tabs on chrome etc.. and now I can barely use my system.

I've got the performance settings in xorg.conf

    |       |--> Device "Device0"
    |       |       |--> Driver "nvidia"
    |       |       |--> VendorName "NVIDIA Corporation"
    |       |       |--> BoardName "GeForce GTX 260"
    |       |       |--> Option "UseEvents" "On"
    |       |       |--> Option "Coolbits" "1"
    |       |       |--> Option "RenderAccel" "O"

I haven't changed anything as far as programs I am running, and since this bug was introduced in the last big update I was wondering if there was a known issue that i could track, or if anyone has any suggestions on how to track down the offender that is causing Xorg to run like this?

share|improve this question
    
does the problem go away if you boot using an older kernel (press shift on boot to display your Grub)? –  fossfreedom Jan 30 '12 at 23:55
    
@fossfreedom I haven't tried an older kernel, I have come to a better understanding however. I believe this has something to do with chrome and chrome-dev. This did start happening after the kernel update last week and a large amount of other packages were updated as well. I have been watching my processes since my last reboot, after modifying the xorg.conf, what i posted above actually includes my recent modification, I just dumped it after I had made the change and before I booted I posted the above. RenderAccel was added I believe this works in conjunction with UseEvents to stabilize. –  Levi De Haan Jan 31 '12 at 5:56
    
I also haven't run chrome-dev but I've been watching my processes for the past 5 hours and memory is still being eaten up at a rather steady pace. So I have implemented sync; echo 3 > /proc/sys/vm/drop_caches in order to bring it down once it gets up to about 19GB and it reduces it down to 8 incredibly So something has gone awry in some program I am using. I am going to have to either methodically kill programs to find the leak or wait till another update :D when I have time and whether or not the next update fixes it shall be a coin toss –  Levi De Haan Jan 31 '12 at 5:58
    
OK So I updated to the next kernel 3.0.0-16.28 generic and I'm having no more issues, I think this has to do with the Intel fix I saw in the changelog –  Levi De Haan Feb 3 '12 at 8:34
    
excellent news - please can you expand and add your comment as an answer - you can accept it... and we can vote on it as well. Well done. –  fossfreedom Feb 3 '12 at 9:19
add comment

closed as too localized by Jorge Castro, hexafraction, Tom Brossman, John S Gruber, maythux Oct 13 '12 at 4:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 2 down vote accepted

Updating the kernel to the next revision fixed the problem.

A couple days after this post there was a new release to the kernel and I believe that was 3.0.0-16.28 in the update log I saw there was a fix for Intel processors so I believe this fixed the issue.

On a side note I would recommend to all to add the Xorg.conf modifications I added in an attempt to fix the CPU load problem:

Option "UseEvents" "On"
Option "RenderAccel" "O"

This has made my setup run even snappier if you can believe it. :D

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.