Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I first installed Ubuntu I choose NOT to ask me for a password at login. That was ok for that moment cause it didn't ask me any password at login. But now I want to be asked for a login password. I changed the settings to Not start automatically but it doesn't work. My Ubuntu doesn't ask me password at login. What should I do now?

In the automatic login box (in the user accounts setting window) I have it checked to off (0 or Off), the thing is that my LightDM login screen gives me only a "Start Session" button below my user name, instead of the usual password field.

share|improve this question
    
Can you try checking the box as that answer recommends? –  Jorge Castro Jan 30 '12 at 21:54
    
In the automatic login box (in the user accounts setting window) i have it checked to off (0 or Off), the thing is that my LightDM login screen gives me only a "Start Session" button below my user name, instead of the usual password field. –  Ubu Jan 30 '12 at 22:02
    
no updates yet?? –  Ubu Feb 1 '12 at 21:57
    
I've got a similar problem. I got a computer with Ubuntu which I hadn't ever used before. Initially, I disabled the function of using password upon log-in, but then changed my mind and set a password in Terminal. The result is that when logging in, I'm never asked for password. I spent hours searching in forums for help and found that lots of people had issues with passwords. Automatic login option in System Settings is Off. I've established and disabled various keyrings, but nothing changes. I used the command "sudo gpasswd -d username nopasswdlogin". No change. As an ultimate irony, when the –  user152977 Apr 27 '13 at 18:01
add comment

2 Answers

up vote 9 down vote accepted

Thanks to user sisco311 from ubuntuforums.org for this answer.

I didn't try it but the link posted above shows a command line:

sudo gpasswd -d $USER nopasswdlogin 

that should work. I did it using the GUI.

The thing is that my user was in the nopasswdlogin group. I had to install the gnome-system-tools which has the GUI to manage users and groups. Then I ran the users-groups manager and change my user to NOT be part of the nopasswdlogin group. Problem Solved. I do have a remaining question: why or how did my user got into that group?

share|improve this answer
add comment

On distributions that use lightdm (xubuntu, ubuntu-studio, ...) you can simply edit

/etc/lightdm/lightdm.conf

If you want user "blah" to auto-login, add the line:

autologin-user=blah

If you want to be prompted for a password when the system boots, just remove that line, or comment it out (ie. place a # sign at the beginning).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.