Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was rocking out to a crazy remix with my headphones plugged in, and someone sitting next to me informed me that the music was also coming out of my speakers. How do I make it so that when I plug headphones in, my speakers turn off?

share|improve this question

closed as too localized by Tom Brossman, LnxSlck, Jorge Castro, Eliah Kagan, Mitch Oct 3 '12 at 5:35

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Possibly related: askubuntu.com/questions/6993/internal-microphone-not-working –  User Oct 25 '10 at 5:47
    
This answer helped me to get rid of this problem. My card was an Intel card. –  Anwar Shah Sep 23 '12 at 3:23
    
possible duplicate of Sound from both headphones and speakers –  Eliah Kagan Oct 3 '12 at 0:22
add comment

2 Answers 2

up vote 7 down vote accepted

This is probably an alsa issue. I had the same problem, but it got reported as a bug and fixed.

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/477226

share|improve this answer
    
+1: This is an ALSA bug. In addition to whatever workaround you can get, please file it - our audio maintainer is pretty good with these :) The driver needs to have a correct mapping of all the various inputs your sound hardware has - one of which is a “you've got headphones plugged in” signal - and not all systems have correct mappings. Running “ubuntu-bug” should get you the symptoms-based reporter, where you can get the relevant audio logs to a bug. –  RAOF Jul 29 '10 at 2:58
    
It has worked for me since the upgrade to 10.10 on hda intel platforms. the previous solution was to open sound preferences, which triggered a probe and changeover to headphones. in my opinion, not a bug...tradeoff for speed increase by not polling the interface –  hbdgaf Nov 29 '10 at 21:03
add comment

I had the same issue. It appears that the new kernel did not correctly detect the sound card model that you have. You will have to edit the /etc/modprobe.d/alsa-base.conf file and set the model manually with

options snd-hda-intel model=<model>

Unfortunately, finding the correct sound card model can take a little guess work. I took me several tries to find the sound card model that would detect the headphones correctly.

This link gives a list of sound card model: http://ubuntuforums.org/showthread.php?t=1043568

More information can be found on the Ubuntu Wiki.

share|improve this answer
    
If you have to do this, file a bug too; the kernel should detect the module automatically. –  Jeremy Kerr Jul 29 '10 at 5:57
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.